summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/transmission/files/transmission-2.31-0001-configure.ac.patch')
-rw-r--r--net-p2p/transmission/files/transmission-2.31-0001-configure.ac.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/transmission/files/transmission-2.31-0001-configure.ac.patch b/net-p2p/transmission/files/transmission-2.31-0001-configure.ac.patch
new file mode 100644
index 000000000000..1ccaf4392559
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-2.31-0001-configure.ac.patch
@@ -0,0 +1,47 @@
+From 5ca762c520be7e0182ed3cb8371c227d6e38d93a Mon Sep 17 00:00:00 2001
+From: Peter Volkov <pva@gentoo.org>
+Date: Thu, 16 Jun 2011 12:46:48 +0400
+Subject: [PATCH 1/3] configure.ac: Drop redudant code/indentation.
+
+---
+ configure.ac | 16 ++++------------
+ 1 files changed, 4 insertions(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7e239bf..7f17a55 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -217,26 +217,18 @@ AC_CHECK_LIB([rt],
+
+ AC_MSG_CHECKING([µTP])
+ build_utp="no"
+-if test "x$CXX" = "x" ; then
+- have_utp="no"
+-else
+- have_utp="yes"
+-fi
+ AC_ARG_ENABLE([utp],
+ AS_HELP_STRING([--enable-utp],[build µTP support]),
+ [want_utp=${enableval}],
+- [want_utp=${have_utp}])
++ [want_utp="yes"])
+ if test "x$want_utp" = "xyes" ; then
+- if test "x$have_utp" = "xyes"; then
++ if test "x$CXX" != "x" ; then
+ LIBUTP_CFLAGS="-I\$(top_srcdir)/third-party/"
+- LIBUTP_LIBS="\$(top_builddir)/third-party/libutp/libutp.a"
+- if test "x$libutp_extra_libs" != "x" ; then
+- LIBUTP_LIBS="$LIBUTP_LIBS $libutp_extra_libs"
+- fi
++ LIBUTP_LIBS="\$(top_builddir)/third-party/libutp/libutp.a $libutp_extra_libs"
+ AC_DEFINE([WITH_UTP],[1])
+ build_utp="yes"
+ else
+- AC_MSG_ERROR("Unable to build uTP support -- C++ compiler not found")
++ AC_MSG_ERROR("Unable to build uTP support -- C++ compiler not found; consider --disable-utp")
+ fi
+ fi
+ AC_SUBST(LIBUTP_CFLAGS)
+--
+1.7.3.4
+