summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild')
-rw-r--r--net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild38
1 files changed, 7 insertions, 31 deletions
diff --git a/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild b/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
index 1e9efc14e5b7..31b47c88cb25 100644
--- a/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
+++ b/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild,v 1.1 2009/07/31 09:26:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild,v 1.2 2009/07/31 11:03:01 scarabeus Exp $
inherit eutils linux-info
@@ -12,18 +12,18 @@ MY_P=${PN}-${MY_PV}-lnx
DESCRIPTION="Hamachi is a secure mediated peer to peer."
HOMEPAGE="http://hamachi.cc"
LICENSE="as-is"
-SRC_URI=" !pentium? ( http://files.hamachi.cc/linux/${MY_P}.tar.gz )
- pentium? ( http://files.hamachi.cc/linux/${MY_P}-pentium.tar.gz )"
+SRC_URI="sse? ( http://files.hamachi.cc/linux/${MY_P}.tar.gz )
+ !sse? ( http://files.hamachi.cc/linux/${MY_P}-pentium.tar.gz )"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="pentium"
+IUSE="sse"
RESTRICT="strip mirror"
# Set workdir for both hamachi versions
-if use pentium; then
- S=${WORKDIR}/${MY_P}-pentium
-else
+if use sse; then
S=${WORKDIR}/${MY_P}
+else
+ S=${WORKDIR}/${MY_P}-pentium
fi
pkg_preinst() {
@@ -38,15 +38,6 @@ pkg_setup() {
check_extra_config
}
-src_unpack() {
- # Unpack the correct Hamachi version
- if use !pentium; then
- unpack ${MY_P}.tar.gz
- else
- unpack ${MY_P}-pentium.tar.gz
- fi
-}
-
src_compile() {
# Compile Tuncfg
make -sC "${S}"/tuncfg || die "Compiling of tunecfg failed"
@@ -81,21 +72,6 @@ src_install() {
}
pkg_postinst() {
- if use pentium; then
- einfo "Remember, you set the pentium USE flag!"
- einfo So, you installed the version for older x86 systems!
- einfo If your CPU is greater than Intel Pentium / AMD K6,
- einfo remove the pentium USE flag and try this version!
- fi
-
- if use !pentium; then
- ewarn "If you are seeing 'illegal instruction' error when trying"
- ewarn "to run Hamachi client, set the pentium USE flag!"
- ewarn "It enables binaries built specifically for older"
- ewarn "x86 platforms, like Intel Pentium or AMD K6,"
- ewarn "with all optimizations turned off."
- fi
-
einfo "To start Hamachi just type:"
einfo "/etc/init.d/hamachi start"