summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cisco-vpnclient-3des/files/2.6.24.patch')
-rw-r--r--net-misc/cisco-vpnclient-3des/files/2.6.24.patch87
1 files changed, 55 insertions, 32 deletions
diff --git a/net-misc/cisco-vpnclient-3des/files/2.6.24.patch b/net-misc/cisco-vpnclient-3des/files/2.6.24.patch
index 14f7485c38bb..16680bcf2397 100644
--- a/net-misc/cisco-vpnclient-3des/files/2.6.24.patch
+++ b/net-misc/cisco-vpnclient-3des/files/2.6.24.patch
@@ -1,6 +1,6 @@
diff -Nur vpnclient/GenDefs.h vpnclient.new/GenDefs.h
---- vpnclient/GenDefs.h 2007-08-22 21:30:31.000000000 +0200
-+++ vpnclient.new/GenDefs.h 2008-01-25 08:56:46.000000000 +0100
+--- vpnclient/GenDefs.h 2005-11-22 04:43:57.000000000 -0500
++++ vpnclient.new/GenDefs.h 2008-02-03 22:37:16.000000000 -0500
@@ -105,6 +105,12 @@
#define _INTPTR_T_DEFINED
#endif
@@ -22,10 +22,22 @@ diff -Nur vpnclient/GenDefs.h vpnclient.new/GenDefs.h
typedef int BOOL;
+diff -Nur vpnclient/Makefile vpnclient.new/Makefile
+--- vpnclient/Makefile 2005-11-22 04:43:57.000000000 -0500
++++ vpnclient.new/Makefile 2008-02-03 22:40:31.000000000 -0500
+@@ -12,7 +12,7 @@
+ SOURCE_OBJS := linuxcniapi.o frag.o IPSecDrvOS_linux.o interceptor.o linuxkernelapi.o
+
+ ifeq ($(SUBARCH),x86_64)
+-CFLAGS += -mcmodel=kernel -mno-red-zone
++EXTRA_CFLAGS += -mcmodel=kernel -mno-red-zone
+ NO_SOURCE_OBJS := libdriver64.so
+ else
+ NO_SOURCE_OBJS := libdriver.so
diff -Nur vpnclient/interceptor.c vpnclient.new/interceptor.c
---- vpnclient/interceptor.c 2007-08-22 21:30:31.000000000 +0200
-+++ vpnclient.new/interceptor.c 2008-01-25 09:50:52.000000000 +0100
-@@ -28,6 +28,10 @@
+--- vpnclient/interceptor.c 2008-02-03 22:39:23.000000000 -0500
++++ vpnclient.new/interceptor.c 2008-02-03 22:37:16.000000000 -0500
+@@ -27,6 +27,10 @@
#include <linux/udp.h>
#include <net/protocol.h>
@@ -36,16 +48,22 @@ diff -Nur vpnclient/interceptor.c vpnclient.new/interceptor.c
#include "linux_os.h"
#include "vpn_ioctl_linux.h"
-@@ -48,7 +52,7 @@
+@@ -47,7 +51,13 @@
unsigned long rx_bytes;
/*methods of the cipsec network device*/
-static int interceptor_init(struct net_device *);
-+static void interceptor_init(struct net_device *);
++static
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,24)
++void
++#else
++int
++#endif
++interceptor_init(struct net_device *);
static struct net_device_stats *interceptor_stats(struct net_device *dev);
static int interceptor_ioctl(struct net_device *dev, struct ifreq *ifr,
int cmd);
-@@ -107,18 +111,27 @@
+@@ -91,15 +101,33 @@
BINDING Bindings[MAX_INTERFACES];
@@ -66,40 +84,45 @@ diff -Nur vpnclient/interceptor.c vpnclient.new/interceptor.c
.notifier_call = handle_netdev_event,
};
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
--static int
-+static void
- #else
--static int __init
-+static void __init
- #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
++static
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,24)
++void
++#else
++int
++#endif
++#else
+ static int __init
++#endif
interceptor_init(struct net_device *dev)
{
-@@ -133,8 +146,6 @@
+ ether_setup(dev);
+@@ -113,8 +141,9 @@
dev->flags |= IFF_NOARP;
dev->flags &= ~(IFF_BROADCAST | IFF_MULTICAST);
kernel_memset(dev->broadcast, 0xFF, ETH_ALEN);
-
- return 0;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
++ return 0;
++#endif
}
static struct net_device_stats *
-@@ -362,8 +373,13 @@
-
- dp = NULL;
+@@ -344,7 +373,11 @@
num_target_devices = 0;
-+
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
-- for_each_netdev(dp)
-+ for_each_netdev(
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,24)
-+ &init_net,
-+#endif
-+ dp)
- #else
- for (dp = dev_base; dp != NULL; dp = dp->next)
- #endif
-@@ -919,15 +935,29 @@
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
+- for_each_netdev(dp)
++ for_each_netdev(
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,24)
++ &init_net,
++ #endif
++ dp)
+ #else
+ for (dp = dev_base; dp != NULL; dp = dp->next)
+ #endif
+@@ -843,15 +876,29 @@
rc = CniPluginLoad(&pcDeviceName, &PCNICallbackTable);
@@ -130,7 +153,7 @@ diff -Nur vpnclient/interceptor.c vpnclient.new/interceptor.c
CniPluginUnload();
}
-@@ -947,7 +977,11 @@
+@@ -871,7 +918,11 @@
cleanup_frag_queue();
CniPluginUnload();