summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/ChangeLog7
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.3.9.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 1e68913e2150..c40f03218df0 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.33 2009/08/05 21:21:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.34 2009/09/06 15:15:18 nirbheek Exp $
+
+*gtk-vnc-0.3.9 (06 Sep 2009)
+
+ 06 Sep 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +gtk-vnc-0.3.9.ebuild:
+ Bump to 0.3.9 -- bugfixes + SASL & MS Logon auth support
05 Aug 2009; Markus Meier <maekke@gentoo.org> gtk-vnc-0.3.8-r1.ebuild:
x86 stable, bug #279511
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.3.9.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.3.9.ebuild
new file mode 100644
index 000000000000..83f0780409ca
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.3.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.3.9.ebuild,v 1.1 2009/09/06 15:15:18 nirbheek Exp $
+
+EAPI="2"
+
+inherit base gnome.org
+
+DESCRIPTION="VNC viewer widget for GTK."
+HOMEPAGE="http://live.gnome.org/gtk-vnc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples python sasl"
+
+# libview is used in examples/gvncviewer -- no need
+# TODO: review nsplugin when it will be considered less experimental
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=net-libs/gnutls-1.4
+ x11-libs/cairo
+ python? ( >=dev-python/pygtk-2 )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with examples) \
+ $(use_with python) \
+ $(use_with sasl) \
+ --with-coroutine=gthread \
+ --without-libview
+}