summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/bind-tools/bind-tools-9.3.2-r3.ebuild')
-rw-r--r--net-dns/bind-tools/bind-tools-9.3.2-r3.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-dns/bind-tools/bind-tools-9.3.2-r3.ebuild b/net-dns/bind-tools/bind-tools-9.3.2-r3.ebuild
new file mode 100644
index 000000000000..4732fe72a2bb
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.3.2-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.3.2-r3.ebuild,v 1.1 2006/07/04 19:28:24 voxus Exp $
+
+inherit flag-o-matic
+
+MY_P=${P//-tools}
+MY_P=${MY_P/_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="bind tools: dig, nslookup, and host"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV/_}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="idn ipv6"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+
+ use idn && {
+ epatch ${S}/contrib/idn/idnkit-1.0-src/patch/bind9/bind-${PV}-patch
+
+ cd ${S}/contrib/idn/idnkit-1.0-src
+ epatch ${FILESDIR}/${PN}-configure.patch
+ }
+}
+
+src_compile() {
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+
+ econf ${myconf} || die "Configure failed"
+
+ cd ${S}/lib
+ emake -j1 || die "make failed in /lib"
+
+ cd ${S}/bin/dig
+ emake -j1 || die "make failed in /bin/dig"
+
+ cd ${S}/lib/lwres/
+ emake -j1 || die "make failed in /lib/lwres"
+
+ cd ${S}/bin/nsupdate/
+ emake -j1 || die "make failed in /bin/nsupdate"
+
+ use idn && {
+ cd ${S}/contrib/idn/idnkit-1.0-src
+ econf || die "idn econf failed"
+ emake -j1 || die "idn emake failed"
+ }
+}
+
+src_install() {
+ dodoc README CHANGES FAQ
+
+ cd ${S}/bin/dig
+ dobin dig host nslookup || die
+ doman dig.1 host.1 nslookup.1 || die
+
+ cd ${S}/bin/nsupdate
+ dobin nsupdate || die
+ doman nsupdate.8 || die
+ dohtml nsupdate.html || die
+}