summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-plugins/files/install-opts-fix.diff')
-rw-r--r--net-analyzer/nagios-plugins/files/install-opts-fix.diff74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/files/install-opts-fix.diff b/net-analyzer/nagios-plugins/files/install-opts-fix.diff
new file mode 100644
index 000000000000..20a8424e461e
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/install-opts-fix.diff
@@ -0,0 +1,74 @@
+diff -urh nagiosplug-1.3-beta1.new/Makefile.in nagiosplug-1.3-beta1/Makefile.in
+--- nagiosplug-1.3-beta1.new/Makefile.in 2002-06-13 07:02:17.000000000 -0700
++++ nagiosplug-1.3-beta1/Makefile.in 2002-10-30 20:41:54.000000000 -0800
+@@ -68,7 +68,6 @@
+ EXTRAS = @EXTRAS@
+ HOSTNAME = @HOSTNAME@
+ INSTALL = @INSTALL@
+-INSTALL_OPTS = @INSTALL_OPTS@
+ LDAPINCLUDE = @LDAPINCLUDE@
+ LDAPLIBS = @LDAPLIBS@
+ MYSQLLIBS = @MYSQLLIBS@
+diff -urh nagiosplug-1.3-beta1.new/configure.in nagiosplug-1.3-beta1/configure.in
+--- nagiosplug-1.3-beta1.new/configure.in 2002-06-12 20:03:07.000000000 -0700
++++ nagiosplug-1.3-beta1/configure.in 2002-10-30 20:42:50.000000000 -0800
+@@ -46,8 +46,6 @@
+ AC_ARG_WITH(nagios_group,--with-nagios-group=<group> sets group name to run nagios,nagios_grp=$withval,nagios_grp=nagios)
+ AC_SUBST(nagios_usr)
+ AC_SUBST(nagios_grp)
+-INSTALL_OPTS="-o $nagios_usr -g $nagios_grp"
+-AC_SUBST(INSTALL_OPTS)
+
+ AC_ARG_WITH(trusted_path,--with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin sets trusted path for executables called by scripts,trusted_path=$withval,trusted_path=/bin:/sbin:/usr/bin:/usr/sbin)
+ AC_SUBST(trusted_path)
+@@ -158,7 +156,7 @@
+ dnl Check for mysql libraries
+ _SAVEDLIBS="$LIBS"
+ _SAVEDCPPFLAGS="$CPPFLAGS"
+-CPPFLAGS="-I/usr/include"
++CPPFLAGS="-I/usr/include/mysql"
+ AC_ARG_WITH(mysqllibdir,--with-mysqllibdir=<dir> sets path to mysql libraries,[MYSQLLIBDIR=$withval])
+ if test -n "$MYSQLLIBS"; then
+ AC_CHECK_LIB(mysqlclient,mysql_init,MYSQLLIBS="-lmysqlclient -lz" check_mysql_LDFLAGS="-L$MYSQLLIBDIR",,-L$MYSQLLIBDIR -lz)
+diff -urh nagiosplug-1.3-beta1.new/plugins/Makefile.am nagiosplug-1.3-beta1/plugins/Makefile.am
+--- nagiosplug-1.3-beta1.new/plugins/Makefile.am 2002-02-27 22:42:57.000000000 -0800
++++ nagiosplug-1.3-beta1/plugins/Makefile.am 2002-10-30 20:41:54.000000000 -0800
+@@ -31,7 +31,6 @@
+ test:
+ perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
+
+-AM_INSTALL_PROGRAM_FLAGS = @INSTALL_OPTS@
+
+ ##############################################################################
+ # the actual targets
+diff -urh nagiosplug-1.3-beta1.new/plugins/Makefile.in nagiosplug-1.3-beta1/plugins/Makefile.in
+--- nagiosplug-1.3-beta1.new/plugins/Makefile.in 2002-06-13 07:02:17.000000000 -0700
++++ nagiosplug-1.3-beta1/plugins/Makefile.in 2002-10-30 20:41:54.000000000 -0800
+@@ -67,7 +67,6 @@
+ EXTRAS = @EXTRAS@
+ HOSTNAME = @HOSTNAME@
+ INSTALL = @INSTALL@
+-INSTALL_OPTS = @INSTALL_OPTS@
+ LDAPINCLUDE = @LDAPINCLUDE@
+ LDAPLIBS = @LDAPLIBS@
+ MYSQLLIBS = @MYSQLLIBS@
+@@ -144,8 +143,6 @@
+
+ TESTS = @PLUGIN_TEST@
+
+-AM_INSTALL_PROGRAM_FLAGS = @INSTALL_OPTS@
+-
+ ##############################################################################
+ # the actual targets
+
+diff -urh nagiosplug-1.3-beta1.new/plugins-scripts/Makefile.in nagiosplug-1.3-beta1/plugins-scripts/Makefile.in
+--- nagiosplug-1.3-beta1.new/plugins-scripts/Makefile.in 2002-06-13 07:02:17.000000000 -0700
++++ nagiosplug-1.3-beta1/plugins-scripts/Makefile.in 2002-10-30 20:41:54.000000000 -0800
+@@ -67,7 +67,6 @@
+ EXTRAS = @EXTRAS@
+ HOSTNAME = @HOSTNAME@
+ INSTALL = @INSTALL@
+-INSTALL_OPTS = @INSTALL_OPTS@
+ LDAPINCLUDE = @LDAPINCLUDE@
+ LDAPLIBS = @LDAPLIBS@
+ MYSQLLIBS = @MYSQLLIBS@