summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/iptstate')
-rw-r--r--net-analyzer/iptstate/ChangeLog8
-rw-r--r--net-analyzer/iptstate/iptstate-2.2.5.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/net-analyzer/iptstate/ChangeLog b/net-analyzer/iptstate/ChangeLog
index d7a9ccd37fa9..3a5da0cf8ca7 100644
--- a/net-analyzer/iptstate/ChangeLog
+++ b/net-analyzer/iptstate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/iptstate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptstate/ChangeLog,v 1.37 2012/02/05 18:25:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptstate/ChangeLog,v 1.38 2012/06/03 08:41:38 ssuominen Exp $
+
+*iptstate-2.2.5 (03 Jun 2012)
+
+ 03 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +iptstate-2.2.5.ebuild:
+ Version bump. Use correct license (ZLIB instead of as-is). Stop forcing -g
+ and -O2 in CXXFLAGS.
05 Feb 2012; Raúl Porcel <armin76@gentoo.org> iptstate-2.2.1.ebuild,
iptstate-2.2.2.ebuild, iptstate-2.2.3.ebuild:
diff --git a/net-analyzer/iptstate/iptstate-2.2.5.ebuild b/net-analyzer/iptstate/iptstate-2.2.5.ebuild
new file mode 100644
index 000000000000..156b9c5839f1
--- /dev/null
+++ b/net-analyzer/iptstate/iptstate-2.2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptstate/iptstate-2.2.5.ebuild,v 1.1 2012/06/03 08:41:38 ssuominen Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="IP Tables State displays states being kept by iptables in a top-like format"
+HOMEPAGE="http://www.phildev.net/iptstate/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7
+ >=net-libs/libnetfilter_conntrack-0.0.50"
+DEPEND=${RDEPEND}
+
+src_prepare() {
+ sed -i \
+ -e 's:?= -g -Wall -O2:+= -Wall:' \
+ -e 's:$(CXX):& $(LDFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CXX
+ emake
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ dodoc BUGS Changelog CONTRIB README WISHLIST
+}