summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/step/step-4.2.2.ebuild')
-rw-r--r--kde-base/step/step-4.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/step/step-4.2.2.ebuild b/kde-base/step/step-4.2.2.ebuild
new file mode 100644
index 000000000000..cf55bda1f97d
--- /dev/null
+++ b/kde-base/step/step-4.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.2.2.ebuild,v 1.1 2009/04/12 06:45:26 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc +gsl +qalculate"
+
+DEPEND="
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.12 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.6-r1 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_with qalculate Qalculate)"
+
+ kde4-meta_src_configure
+}