summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/oxygen-icons/oxygen-icons-4.6.5.ebuild')
-rw-r--r--kde-base/oxygen-icons/oxygen-icons-4.6.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-base/oxygen-icons/oxygen-icons-4.6.5.ebuild b/kde-base/oxygen-icons/oxygen-icons-4.6.5.ebuild
new file mode 100644
index 000000000000..7cc80574ee7d
--- /dev/null
+++ b/kde-base/oxygen-icons/oxygen-icons-4.6.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/oxygen-icons-4.6.5.ebuild,v 1.1 2011/07/09 15:14:24 alexxy Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdesupport"
+else
+ # Upstream does not ship releases properly so we dont want all versions
+ MY_PV="4.6.5"
+ MY_P="${PN}-${MY_PV}"
+fi
+KDE_REQUIRED="never"
+inherit kde4-base
+
+DESCRIPTION="Oxygen SVG icon theme."
+HOMEPAGE="http://www.oxygen-icons.org/"
+# Note that the upstream tarball is .bz2, ours is .xz -- if upstream
+# changes its compression format to .xz, we will need to change the
+# filename of one of the tarballs
+[[ ${PV} == *9999 ]] || \
+SRC_URI="
+ !bindist? ( http://dev.gentoo.org/~alexxy/${MY_P}.tar.xz )
+ bindist? ( ${SRC_URI//${PV}/${MY_PV}} )
+"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="aqua bindist"
+
+DEPEND="
+ !bindist? ( app-arch/xz-utils )
+"
+RDEPEND=""
+
+[[ ${PV} == *9999 ]] || S=${WORKDIR}/${MY_P}
+
+# Block conflicting packages
+add_blocker kdebase-data '<4.2.67'
+add_blocker kdepim-icons 4.2.89
+add_blocker step 4.2.98
+add_blocker kmail '<4.3.2'