summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/lisa/lisa-3.5.0_beta2.ebuild')
-rw-r--r--kde-base/lisa/lisa-3.5.0_beta2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/lisa/lisa-3.5.0_beta2.ebuild b/kde-base/lisa/lisa-3.5.0_beta2.ebuild
new file mode 100644
index 000000000000..c96278ebcf16
--- /dev/null
+++ b/kde-base/lisa/lisa-3.5.0_beta2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lisa/lisa-3.5.0_beta2.ebuild,v 1.1 2005/10/14 18:42:01 danarmak Exp $
+
+KMNAME=kdenetwork
+KMMODULE=lanbrowsing
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE Lan Information Server - allows KDE desktops to share information over a network"
+KEYWORDS="~amd64"
+IUSE=""
+KMEXTRA="doc/kcontrol/lanbrowser"
+
+src_install() {
+ kde-meta_src_install
+
+ chmod u+s ${D}/${KDEDIR}/bin/reslisa
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+
+ for x in /etc/lisarc /etc/reslisarc; do
+ echo '# Default lisa/reslisa configfile' > $D/$x
+ done
+} \ No newline at end of file