summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/cantor/cantor-4.8.0.ebuild')
-rw-r--r--kde-base/cantor/cantor-4.8.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/kde-base/cantor/cantor-4.8.0.ebuild b/kde-base/cantor/cantor-4.8.0.ebuild
deleted file mode 100644
index 6bd337588ccf..000000000000
--- a/kde-base/cantor/cantor-4.8.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.8.0.ebuild,v 1.1 2012/01/25 18:17:14 johu Exp $
-
-EAPI=4
-
-KDE_HANDBOOK="optional"
-KDE_SCM="git"
-inherit kde4-base
-
-DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="analitza debug ps +R"
-
-# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-RDEPEND="
- analitza? ( $(add_kdebase_dep analitza) )
- ps? ( app-text/libspectre )
- R? ( dev-lang/R )
-"
-DEPEND="${RDEPEND}
- >=dev-cpp/eigen-2.0.3:2
-"
-
-src_configure() {
- mycmakeargs+="
- $(cmake-utils_use_with analitza Analitza)
- $(cmake-utils_use_with ps LibSpectre)
- $(cmake-utils_use_with R)
- "
- kde4-base_src_configure
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- if ! use R; then
- echo
- ewarn "You have decided to build ${PN} with no backend."
- ewarn "To have this application functional, please do one of below:"
- ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
- ewarn " # emerge -vaDu sci-mathematics/maxima"
- echo
- fi
-}