summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.1.ebuild')
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.1.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.1.ebuild
new file mode 100644
index 000000000000..7d57ca2c8125
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.1.ebuild,v 1.1 2011/05/08 19:21:35 voyageur Exp $
+
+inherit gnustep-base
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="opengl xim"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ =gnustep-base/gnustep-gui-${PV%.*}*
+ opengl? ( virtual/opengl virtual/glu )
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ dev-libs/expat
+ media-libs/fontconfig
+ >=media-libs/freetype-2.1.9
+ !gnustep-base/gnustep-back-art
+ !gnustep-base/gnustep-back-cairo"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}