summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/mcl/files')
-rw-r--r--games-mud/mcl/files/0.53.00-dynacomplete.patch11
-rw-r--r--games-mud/mcl/files/0.53.00-vc.patch39
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-fPIC.patch18
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-gcc34.patch12
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-gcc42.patch13
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch11
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-libdir.patch31
7 files changed, 0 insertions, 135 deletions
diff --git a/games-mud/mcl/files/0.53.00-dynacomplete.patch b/games-mud/mcl/files/0.53.00-dynacomplete.patch
deleted file mode 100644
index 3142cf9735c4..000000000000
--- a/games-mud/mcl/files/0.53.00-dynacomplete.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mcl-0.53.00/samples/contrib/DynaComplete.py 1999-09-20 20:10:33.000000000 +0200
-+++ mcl-0.53.00/samples/contrib/DynaComplete.py 1999-09-20 20:10:33.000000000 +0200
-@@ -23,7 +23,7 @@
- self.dict = { }
- self.userwords = { }
- self.lookup = None
-- self.wording = re.compile( '\s*(?P<word>[\w-#]+)' )
-+ self.wording = re.compile( '\s*(?P<word>[\w\-#]+)' )
- self.add_word( 'complete' )
-
- def add_word( self, inword ):
diff --git a/games-mud/mcl/files/0.53.00-vc.patch b/games-mud/mcl/files/0.53.00-vc.patch
deleted file mode 100644
index fc77a4b9b348..000000000000
--- a/games-mud/mcl/files/0.53.00-vc.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -u mcl-0.53.00/Screen.cc mcl-patched/Screen.cc
---- mcl-0.53.00/Screen.cc 2003-09-29 04:51:44.000000000 -0700
-+++ mcl-patched/Screen.cc 2004-07-26 19:22:11.620619536 -0700
-@@ -49,7 +49,8 @@
- // 2.4 with devs (noted by moon@deathmoon.com
- else if (1 == (sscanf(tty, "/dev/vc/%d", &ttyno)))
- sprintf (buf, "/dev/vcc/a%d", ttyno);
-- else {
-+
-+ if ((fd = open (buf, O_WRONLY)) < 0) {
- usingVirtual = false;
- scr_x = scr_y = scr_w = scr_h = 0;
- last_screen = new attrib[width * height];
-@@ -58,13 +59,6 @@
- out = new Buffer(32000);
- }
-
-- if (usingVirtual) {
-- if ((fd = open (buf, O_WRONLY)) < 0) {
-- fprintf (stderr, "\nFailed to open %s: %m. \nPerhaps your permissions are wrong?\n\n", buf);
-- exit (EXIT_FAILURE);
-- }
-- }
--
- init_curses(usingVirtual);
- }
-
-diff -u mcl-0.53.00/main.cc mcl-patched/main.cc
---- mcl-0.53.00/main.cc 2003-09-29 03:39:14.000000000 -0700
-+++ mcl-patched/main.cc 2004-07-26 18:18:01.000000000 -0700
-@@ -50,7 +50,7 @@
- // Do this right at the start, so that a) perl can startup correctly,
- // and b) to avoid any unforseen holes in eg. configfile loading -N
- screen = new Screen();
-- setegid(getgid());
-+ seteuid(getuid());
-
- time (&current_time);
- srand(current_time);
diff --git a/games-mud/mcl/files/mcl-0.53.00-fPIC.patch b/games-mud/mcl/files/mcl-0.53.00-fPIC.patch
deleted file mode 100644
index 0434ef12984a..000000000000
--- a/games-mud/mcl/files/mcl-0.53.00-fPIC.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.in 2004-03-30 11:32:20.422782923 +0000
-+++ Makefile.in 2004-03-30 11:32:36.558806599 +0000
-@@ -108,13 +108,13 @@
- $(CC) $(LDFLAGS) -shared $< -o $@ $(PERL_LDFLAGS) $(LIBPTHREAD)
-
- o/plugins/PerlEmbeddedInterpreter.o: plugins/PerlEmbeddedInterpreter.cc
-- $(CC) -c $(MCL_CFLAGS) $(PERL_CPPFLAGS) $< -o $@
-+ $(CC) -fPIC -c $(MCL_CFLAGS) $(PERL_CPPFLAGS) $< -o $@
-
- o/plugins/python.so: o/plugins/PythonEmbeddedInterpreter.o
- $(CC) $(LDFLAGS) -shared $< -o $@ $(PYTHON_LDFLAGS) $(LIBPTHREAD)
-
- o/plugins/PythonEmbeddedInterpreter.o: plugins/PythonEmbeddedInterpreter.cc
-- $(CC) -c $(MCL_CFLAGS) $(PYTHON_CPPFLAGS) $< -o $@
-+ $(CC) -fPIC -c $(MCL_CFLAGS) $(PYTHON_CPPFLAGS) $< -o $@
-
- install: $(EXE)
- $(INSTALL) -d $(INSTALL_ROOT)$(prefix)/{bin,lib/mcl/{auto,contrib,plugins,sys}}
diff --git a/games-mud/mcl/files/mcl-0.53.00-gcc34.patch b/games-mud/mcl/files/mcl-0.53.00-gcc34.patch
deleted file mode 100644
index f25d9c4eb925..000000000000
--- a/games-mud/mcl/files/mcl-0.53.00-gcc34.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-esdiff -ru mcl-0.53.00/InputLine.cc mcl-0.53.00.new/InputLine.cc
---- mcl-0.53.00/InputLine.cc 2003-09-29 12:37:49.000000000 +0200
-+++ mcl-0.53.00.new/InputLine.cc 2004-07-28 16:40:13.025986752 +0200
-@@ -27,7 +27,7 @@
-
- History::History(int _id) : id (_id), current(0) {
- max_history = config->getOption(opt_histsize);
-- strings = new (char*)[max_history];
-+ strings = new char*[max_history];
- timestamps = new time_t[max_history];
-
- // Hmm, not sure about this
diff --git a/games-mud/mcl/files/mcl-0.53.00-gcc42.patch b/games-mud/mcl/files/mcl-0.53.00-gcc42.patch
deleted file mode 100644
index 553f3c0fe18f..000000000000
--- a/games-mud/mcl/files/mcl-0.53.00-gcc42.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- OutputWindow.cc
-+++ OutputWindow.cc
-@@ -229,8 +229,8 @@
- highlight.len = strlen(s);
-
- // Show on the second line rather than under status bar
-- viewpoint = scrollback >? p-width;
-- viewpoint = viewpoint <? canvas;
-+ viewpoint = scrollback > p-width ? scrollback : p-width;
-+ viewpoint = viewpoint < canvas ? viewpoint : canvas;
- status->setf("Found string '%s'", s);
- }
- }
diff --git a/games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch b/games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch
deleted file mode 100644
index 62bedb8b7c93..000000000000
--- a/games-mud/mcl/files/mcl-0.53.00-glibc2.10.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/PythonEmbeddedInterpreter.cc
-+++ plugins/PythonEmbeddedInterpreter.cc
-@@ -132,7 +132,7 @@
- bool PythonEmbeddedInterpreter::run_quietly(const char *file, const char *args,
- char *result, bool suppress)
- {
-- char *func = strrchr(file, '/');
-+ char *func = strrchr((char *)file, '/');
- char buf[256];
-
- if(func) func++;
diff --git a/games-mud/mcl/files/mcl-0.53.00-libdir.patch b/games-mud/mcl/files/mcl-0.53.00-libdir.patch
deleted file mode 100644
index c9f1341f9bbc..000000000000
--- a/games-mud/mcl/files/mcl-0.53.00-libdir.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.in
-+++ Makefile.in
-@@ -15,7 +15,7 @@
- LDFLAGS=@LDFLAGS@
- LIBS=@LIBS@
- prefix=@prefix@
--INSTALL_ROOT=@INSTALL_ROOT@
-+libdir=@libdir@
- COMPILED_BY=@COMPILED_BY@
- MODULES=@WITH_PERL@ @WITH_PYTHON@
-
-@@ -117,12 +117,13 @@
- $(CC) -c $(MCL_CFLAGS) $(PYTHON_CPPFLAGS) $< -o $@
-
- install: $(EXE)
-- $(INSTALL) -d $(INSTALL_ROOT)$(prefix)/{bin,lib/mcl/{auto,contrib,plugins,sys}}
-- $(INSTALL) $(EXE) $(INSTALL_ROOT)$(prefix)/bin
-- $(INSTALL) o/plugins/*.so $(INSTALL_ROOT)$(prefix)/lib/mcl/plugins || : # There may be no plugins to install
-- $(INSTALL) samples/auto/*.* $(INSTALL_ROOT)$(prefix)/lib/mcl/auto/ # The *.* is desired, not a typo
-- $(INSTALL) samples/contrib/*.* $(INSTALL_ROOT)$(prefix)/lib/mcl/contrib/
-- $(INSTALL) samples/sys/*.* $(INSTALL_ROOT)$(prefix)/lib/mcl/sys/
-+ $(INSTALL) -d $(DESTDIR)$(prefix)/bin
-+ $(INSTALL) -d $(DESTDIR)$(libdir)/mcl/{auto,contrib,plugins,sys}
-+ $(INSTALL) $(EXE) $(DESTDIR)$(prefix)/bin
-+ -$(INSTALL) o/plugins/*.so $(DESTDIR)$(libdir)/mcl/plugins
-+ $(INSTALL) samples/auto/*.* $(DESTDIR)$(libdir)/mcl/auto/
-+ $(INSTALL) samples/contrib/*.* $(DESTDIR)$(libdir)/mcl/contrib/
-+ $(INSTALL) samples/sys/*.* $(DESTDIR)$(libdir)/mcl/sys/
-
-
- include admin/Makefile