summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/thor/thor-0.18.1.ebuild')
-rw-r--r--dev-ruby/thor/thor-0.18.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/thor/thor-0.18.1.ebuild b/dev-ruby/thor/thor-0.18.1.ebuild
deleted file mode 100644
index 279ab3c27950..000000000000
--- a/dev-ruby/thor/thor-0.18.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.18.1.ebuild,v 1.6 2014/11/25 11:34:25 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="http://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/fakeweb-1.3
- dev-ruby/childlabor
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/SimpleCov.start/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}