summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/prawn-security/prawn-security-0.7.1.ebuild')
-rw-r--r--dev-ruby/prawn-security/prawn-security-0.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild b/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild
new file mode 100644
index 000000000000..f6753167b734
--- /dev/null
+++ b/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild,v 1.1 2010/01/24 15:43:02 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Popular Password Protection & Permissions for Prawn PDFs"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+ruby_add_bdepend "dev-ruby/test-spec dev-ruby/mocha"
+
+ruby_add_rdepend ">=dev-ruby/prawn-core-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}