summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-runner/twisted-runner-12.0.0.ebuild')
-rw-r--r--dev-python/twisted-runner/twisted-runner-12.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/twisted-runner/twisted-runner-12.0.0.ebuild b/dev-python/twisted-runner/twisted-runner-12.0.0.ebuild
new file mode 100644
index 000000000000..be1bab5c185d
--- /dev/null
+++ b/dev-python/twisted-runner/twisted-runner-12.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-12.0.0.ebuild,v 1.1 2012/03/22 07:08:35 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Runner"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted Runner is a process management library and inetd replacement."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/runner"
+
+src_install() {
+ twisted_src_install
+ python_clean_installation_image
+}