summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gnome-python-desktop-base')
-rw-r--r--dev-python/gnome-python-desktop-base/ChangeLog11
-rw-r--r--dev-python/gnome-python-desktop-base/Manifest5
-rw-r--r--dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.22.0.ebuild44
-rw-r--r--dev-python/gnome-python-desktop-base/metadata.xml5
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/gnome-python-desktop-base/ChangeLog b/dev-python/gnome-python-desktop-base/ChangeLog
new file mode 100644
index 000000000000..59550f922b79
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/gnome-python-desktop-base
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.1 2008/09/14 16:27:45 ford_prefect Exp $
+
+*gnome-python-desktop-base-2.22.0 (14 Sep 2008)
+
+ 14 Sep 2008; Arun Raghavan <ford_prefect@gentoo.org> +metadata.xml,
+ +gnome-python-desktop-base-2.22.0.ebuild:
+ Initial import of split gnome-python-desktop. This package installs a
+ common .pc file for all the bindings.
+
diff --git a/dev-python/gnome-python-desktop-base/Manifest b/dev-python/gnome-python-desktop-base/Manifest
new file mode 100644
index 000000000000..cd29a2acdd46
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/Manifest
@@ -0,0 +1,5 @@
+DIST gnome-python-desktop-2.22.0-split.patch.gz 3213 RMD160 be9f3a27050443421e2a710be41539bd8df90a21 SHA1 bad5f80d233a2034768bd1437772914fc96f1453 SHA256 3fcaf681767ee4814c3148627f8ac49a83fad47398c96ace2e28cc8ccaca40c2
+DIST gnome-python-desktop-2.22.0.tar.bz2 571816 RMD160 4a9bc36c379f5fbb6549506c8b8e8bdb63bf0d62 SHA1 6f1a93aacfc256ca878f8f3636a0270580d2354b SHA256 116213b0b0fc3f1fa6771589eab86ccdf5d5024c30a987f3b912da0902be9d37
+EBUILD gnome-python-desktop-base-2.22.0.ebuild 1182 RMD160 43dcb2149d104b73429ffd7deed80484baa90253 SHA1 664a0c4b8e1136075c03119feddab01ff8523db2 SHA256 34f3fb3d465a6be86173030531def1a21d54f4d79bc94e95ceefb04184cd7566
+MISC ChangeLog 413 RMD160 a8e8a8288c9ddfd2c9ab251aba3a1155e82bfed2 SHA1 fd1abdad3b75707ef34d75a94737b7c791377723 SHA256 f4f67c4aa0553285c23707d2c82a2d143c089eea0b240eefa614ce5cc95a504a
+MISC metadata.xml 158 RMD160 c0e2bae8e91bb6be8922bac5e4f597302e06587e SHA1 38f78e9790bcd4382b4a49aa226aa6dda1d3a3d7 SHA256 3a7dbca0fdc557de69783e0663e2d76ddab129ea8a19b2d0ef6d3e5d1b947ce1
diff --git a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.22.0.ebuild b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.22.0.ebuild
new file mode 100644
index 000000000000..c2c5e588ad67
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.22.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.22.0.ebuild,v 1.1 2008/09/14 16:27:45 ford_prefect Exp $
+
+inherit versionator eutils autotools gnome2
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+MY_PN="gnome-python-desktop"
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2
+ mirror://gentoo/${MY_PN}-${PV}-split.patch.gz"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python-desktop eclass
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10.3
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.4.0
+ !<dev-python/gnome-python-extras-2.13
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ gnome2_src_unpack
+ cd "${S}"
+ epatch "${WORKDIR}/${MY_PN}-${PV}-split.patch"
+ eautoreconf
+}
+
+src_compile() {
+ G2CONF="${G2CONF} --disable-allbindings"
+ gnome2_src_compile
+}
diff --git a/dev-python/gnome-python-desktop-base/metadata.xml b/dev-python/gnome-python-desktop-base/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>