summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cffi/cffi-0.3.ebuild')
-rw-r--r--dev-python/cffi/cffi-0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/cffi/cffi-0.3.ebuild b/dev-python/cffi/cffi-0.3.ebuild
new file mode 100644
index 000000000000..3794c060ba16
--- /dev/null
+++ b/dev-python/cffi/cffi-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.3.ebuild,v 1.1 2012/10/10 09:16:12 djc Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.5 2.5-jython"
+
+inherit distutils
+
+DESCRIPTION="Foreign Function Interface for Python calling C code."
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libffi
+ dev-python/pycparser
+ dev-python/pytest
+ dev-python/hgdistver"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" py.test c/ testing/ -x
+ }
+ python_execute_function testing
+}