summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bsddb3/bsddb3-4.1.3.ebuild')
-rw-r--r--dev-python/bsddb3/bsddb3-4.1.3.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/bsddb3/bsddb3-4.1.3.ebuild b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
index b6bd28dddb6e..55f4593315c2 100644
--- a/dev-python/bsddb3/bsddb3-4.1.3.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.11 2004/06/26 21:22:04 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.12 2004/09/26 12:05:16 liquidx Exp $
inherit distutils eutils
@@ -18,11 +18,13 @@ DEPEND="virtual/python
DOCS="README.txt TODO.txt"
-src_compile() {
- distutils_src_compile "--berkeley-db=/usr"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-setup.py.patch
}
src_install() {
- distutils_src_install "--berkeley-db=/usr"
+ distutils_src_install
dohtml docs/*
}