summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog5
-rw-r--r--dev-php/php/files/php-4.3.4-amd64hack.diff28
-rw-r--r--dev-php/php/php-4.3.4-r4.ebuild9
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index e48c478911f2..b73a290aeb32 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-php/php
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.74 2004/01/26 09:36:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.75 2004/02/05 07:30:08 vapier Exp $
*php-4.3.4-r4 (26 Jan 2004)
+ 05 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add amd64 patch #35956 by Ryan C. Gordon.
+
26 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> php-4.3.4-r4.ebuild:
fix bug #39398, revision bump for it.
diff --git a/dev-php/php/files/php-4.3.4-amd64hack.diff b/dev-php/php/files/php-4.3.4-amd64hack.diff
new file mode 100644
index 000000000000..2e36b25b9a08
--- /dev/null
+++ b/dev-php/php/files/php-4.3.4-amd64hack.diff
@@ -0,0 +1,28 @@
+--- ltmain.sh_orig 2004-01-29 02:00:07.202890120 -0500
++++ ltmain.sh 2004-01-29 02:05:30.628721920 -0500
+@@ -2586,6 +2586,12 @@
+ set dummy $deplibs_check_method
+ file_magic_regex=`expr "$deplibs_check_method" : "$2 \(.*\)"`
+ for a_deplib in $deplibs; do
++
++ if test "x$a_deplib" = "x-lc-client" ; then
++ newdeplibs="$newdeplibs $a_deplib"
++ continue
++ fi
++
+ name="`expr $a_deplib : '-l\(.*\)'`"
+ # If $name is empty we are operating on a -L argument.
+ if test -n "$name" && test "$name" != "0"; then
+@@ -2645,6 +2651,12 @@
+ set dummy $deplibs_check_method
+ match_pattern_regex=`expr "$deplibs_check_method" : "$2 \(.*\)"`
+ for a_deplib in $deplibs; do
++
++ if test "x$a_deplib" = "x-lc-client" ; then
++ newdeplibs="$newdeplibs $a_deplib"
++ continue
++ fi
++
+ name="`expr $a_deplib : '-l\(.*\)'`"
+ # If $name is empty we are operating on a -L argument.
+ if test -n "$name" && test "$name" != "0"; then
diff --git a/dev-php/php/php-4.3.4-r4.ebuild b/dev-php/php/php-4.3.4-r4.ebuild
index f39ed746fc00..8e44aec5d870 100644
--- a/dev-php/php/php-4.3.4-r4.ebuild
+++ b/dev-php/php/php-4.3.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.4-r4.ebuild,v 1.1 2004/01/26 09:36:29 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.4-r4.ebuild,v 1.2 2004/02/05 07:30:08 vapier Exp $
PHPSAPI="cli"
inherit php-sapi eutils
@@ -9,6 +9,13 @@ DESCRIPTION="PHP Shell Interpreter"
SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha hppa amd64 ia64"
+src_unpack() {
+ php-sapi_src_unpack
+ if [ "${ARCH}" == "amd64" ] ; then
+ epatch ${FILESDIR}/${P}-amd64hack.diff
+ fi
+}
+
src_compile() {
myconf="${myconf} \
--disable-cgi \