summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/Manifest4
-rw-r--r--dev-php/php/files/digest-php-4.3.3-r22
-rw-r--r--dev-php/php/php-4.3.3-r2.ebuild51
4 files changed, 61 insertions, 3 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 78869f7549a1..8f413efee046 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.60 2003/09/17 03:08:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.61 2003/10/01 21:05:33 robbat2 Exp $
+
+*php-4.3.3-r2 (01 Oct 2003)
+
+ 01 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> php-4.3.3-r2.ebuild:
+ bump rev on ebuild for eclass changes, and move to stable
16 Sep 2003; Robin H. Johnson <robbat2@gentoo.org> php-4.3.3-r1.ebuild:
ncurses cleanup
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 449d3ed07686..b2de15c3af9e 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,11 +1,11 @@
MD5 08c7e0f218a4d640bed169bb21127806 php-5.0_beta1-r1.ebuild 1257
MD5 0d9585a857a06f4d336cf647dd8728d4 php-4.3.2-r3.ebuild 1140
-MD5 57bb8b73e139c8e0e78dba7864acf21a php-4.3.3-r2.ebuild 1207
+MD5 c8cc2dc8ab39618308726f1749d14d61 php-4.3.3-r2.ebuild 1207
MD5 25f97fc9df6d134f3da1b4e5c1414830 php-4.3.2.ebuild 2418
MD5 3eeafc4e390ffd783e014a5ec877e820 php-4.3.2-r2.ebuild 1182
MD5 f1385520cac897796eeae1ad974ac15c php-4.3.3-r1.ebuild 1208
MD5 ff00712ef064fedea5c310204c367b1a php-5.0_beta1.ebuild 1176
-MD5 2687763c64c6d290e803d10627574a1c ChangeLog 9404
+MD5 5c46b2c89408b0fce9cd4ad6eb9283ec ChangeLog 9404
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 ce0950f7facac1bcd6c3f99321f4648a php-4.3.2-r1.ebuild 990
MD5 bc498859e45cdd2924f64ae5ef806239 php-4.3.3.ebuild 1210
diff --git a/dev-php/php/files/digest-php-4.3.3-r2 b/dev-php/php/files/digest-php-4.3.3-r2
new file mode 100644
index 000000000000..1fecdf01d76d
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.3-r2
@@ -0,0 +1,2 @@
+MD5 1171d96104e2ff2cff9e19789a4a1536 php-4.3.3.tar.bz2 3711877
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php/php-4.3.3-r2.ebuild b/dev-php/php/php-4.3.3-r2.ebuild
new file mode 100644
index 000000000000..9ebafccff263
--- /dev/null
+++ b/dev-php/php/php-4.3.3-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.3-r2.ebuild,v 1.1 2003/10/01 21:05:33 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+
+src_compile() {
+ # Readline and Ncurses are CLI PHP only
+ # readline implies ncurses
+ use_ncurses="--without"
+ use ncurses || use readline && use_ncurses="--with"
+ myconf="${myconf} `use_with readline`"
+ myconf="${myconf} ${use_ncurses}-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ installtargets="${installtargets} install-cli"
+ php_src_install
+
+ # php executable is located in ./sapi/cli/
+ exeinto /usr/bin
+ doexe sapi/cli/php
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+}
+pkg_preinst() {
+ php_pkg_preinst
+}