summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.81.0.ebuild')
-rw-r--r--dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.81.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.81.0.ebuild b/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.81.0.ebuild
new file mode 100644
index 000000000000..9f9bc849febe
--- /dev/null
+++ b/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.81.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.81.0.ebuild,v 1.1 2011/08/27 19:27:52 tove Exp $
+
+EAPI=4
+
+MY_PN=Gnome2-VFS
+MODULE_AUTHOR=TSCH
+MODULE_VERSION=1.081
+inherit perl-module
+
+DESCRIPTION="Perl interface to the 2.x series of the Gnome Virtual File System libraries."
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=gnome-base/gnome-vfs-2
+ >=dev-perl/glib-perl-1.120"
+DEPEND="${RDEPEND}
+ >=dev-perl/extutils-depends-0.2
+ >=dev-perl/extutils-pkgconfig-1.03
+ dev-util/pkgconfig"
+
+SRC_TEST=do
+
+src_test(){
+ if [[ ${EUID} == 0 || ${HOME} = /root ]] ; then
+ ewarn "Test skipped. Don't run tests as root."
+ return
+ fi
+ mkdir "${HOME}/.gnome"
+ perl-module_src_test
+}