summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/ChangeLog7
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/ocaml-ctypes/ChangeLog b/dev-ml/ocaml-ctypes/ChangeLog
index be50609dd636..6dcc6b88c980 100644
--- a/dev-ml/ocaml-ctypes/ChangeLog
+++ b/dev-ml/ocaml-ctypes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-ctypes
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ctypes/ChangeLog,v 1.3 2015/03/28 06:56:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ctypes/ChangeLog,v 1.4 2015/04/10 15:28:49 aballier Exp $
+
+*ocaml-ctypes-0.4.1 (10 Apr 2015)
+
+ 10 Apr 2015; Alexis Ballier <aballier@gentoo.org> +ocaml-ctypes-0.4.1.ebuild:
+ version bump
28 Mar 2015; Markus Meier <maekke@gentoo.org> ocaml-ctypes-0.4.0.ebuild:
add ~arm, bug #543604
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.1.ebuild
new file mode 100644
index 000000000000..e2c071269bce
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.1.ebuild,v 1.1 2015/04/10 15:28:49 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ virtual/libffi
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}