summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ulex/ulex-0.5.ebuild')
-rw-r--r--dev-ml/ulex/ulex-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ulex/ulex-0.5.ebuild b/dev-ml/ulex/ulex-0.5.ebuild
new file mode 100644
index 000000000000..16158d521e68
--- /dev/null
+++ b/dev-ml/ulex/ulex-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ulex/ulex-0.5.ebuild,v 1.1 2004/08/08 07:11:03 mattam Exp $
+
+inherit eutils
+
+DESCRIPTION="a lexer generator for unicode"
+HOMEPAGE="http://www.cduce.org"
+SRC_URI="http://www.cduce.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.08
+ >=dev-ml/findlib-0.8"
+
+src_compile() {
+ make all || die
+ make all.opt || die
+}
+
+src_install() {
+ local destdir=`ocamlfind printconf destdir`
+ dodir ${destdir}
+ # dummy ld.conf, packages do not install C libraries
+ make OCAMLFIND_LDCONF=dummy OCAMLFIND_DESTDIR=${D}${destdir} install || die
+ dodoc README CHANGES
+}