summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch')
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch
index f4c600b6887c..4ceb2e8fbfb3 100644
--- a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.06.03-mustbuildclient.patch
@@ -95,3 +95,57 @@ Index: xmlrpc-c-1.06.03/tools/Makefile
.PHONY: all clean distclean install check dep
+Index: xmlrpc-c-1.06.03/xmlrpc-c-config.in
+===================================================================
+--- xmlrpc-c-1.06.03.orig/xmlrpc-c-config.in
++++ xmlrpc-c-1.06.03/xmlrpc-c-config.in
+@@ -108,26 +108,31 @@ while test $# -gt 0; do
+ ;;
+ client|libwww-client)
+ # libwww-client is for backward compatibility
+- the_libs="-lxmlrpc_client $the_libs"
+
+- if test "${MUST_BUILD_WININET_CLIENT}" = "yes"; then
+- the_libs="@WININET_LDADD@ $the_libs"
+- the_rpath="@WININET_RPATH@ $the_rpath"
+- the_wl_rpath="@WININET_WL_RPATH@ $the_wl_rpath"
+- fi
+- if test "${MUST_BUILD_CURL_CLIENT}" = "yes"; then
+- the_libs="@CURL_LDADD@ $the_libs"
+- the_rpath="@CURL_RPATH@ $the_rpath"
+- the_wl_rpath="@CURL_WL_RPATH@ $the_wl_rpath"
+- fi
+- if test "${MUST_BUILD_LIBWWW_CLIENT}" = "yes"; then
+- the_libs="@LIBWWW_LDADD@ $the_libs"
+- the_rpath="@LIBWWW_RPATH@ $the_rpath"
+- the_wl_rpath="@LIBWWW_WL_RPATH@ $the_wl_rpath"
+- fi
+- if test "${needCpp}" = "yes"; then
+- the_libs="-lxmlrpc_client++ $the_libs"
++ if test "${MUST_BUILD_WININET_CLIENT}" = "yes" || \
++ test "${MUST_BUILD_CURL_CLIENT}" = "yes" || \
++ test "${MUST_BUILD_LIBWWW_CLIENT}" = "yes"; then
++ the_libs="-lxmlrpc_client $the_libs"
++
++ if test "${MUST_BUILD_WININET_CLIENT}" = "yes"; then
++ the_libs="@WININET_LDADD@ $the_libs"
++ the_rpath="@WININET_RPATH@ $the_rpath"
++ the_wl_rpath="@WININET_WL_RPATH@ $the_wl_rpath"
+ fi
++ if test "${MUST_BUILD_CURL_CLIENT}" = "yes"; then
++ the_libs="@CURL_LDADD@ $the_libs"
++ the_rpath="@CURL_RPATH@ $the_rpath"
++ the_wl_rpath="@CURL_WL_RPATH@ $the_wl_rpath"
++ fi
++ if test "${MUST_BUILD_LIBWWW_CLIENT}" = "yes"; then
++ the_libs="@LIBWWW_LDADD@ $the_libs"
++ the_rpath="@LIBWWW_RPATH@ $the_rpath"
++ the_wl_rpath="@LIBWWW_WL_RPATH@ $the_wl_rpath"
++ fi
++ if test "${needCpp}" = "yes"; then
++ the_libs="-lxmlrpc_client++ $the_libs"
++ fi
++ fi
+ ;;
+ --version)
+ echo "@VERSION@"