summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libhoard/libhoard-2.1.2d.ebuild')
-rw-r--r--dev-libs/libhoard/libhoard-2.1.2d.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libhoard/libhoard-2.1.2d.ebuild b/dev-libs/libhoard/libhoard-2.1.2d.ebuild
new file mode 100644
index 000000000000..fd4cead72749
--- /dev/null
+++ b/dev-libs/libhoard/libhoard-2.1.2d.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhoard/libhoard-2.1.2d.ebuild,v 1.1 2003/07/31 20:12:12 rphillips Exp $
+
+inherit libtool
+
+DESCRIPTION="A fast, scalable and memory-efficient allocator for multiprocessors"
+HOMEPAGE="http://www.hoard.org/"
+SRC_URI="http://www.cs.umass.edu/%7Eemery/software/libhoard-2.1.2d.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # update libtool
+ elibtoolize
+
+ # enable the GNU extensions
+ export CPPFLAGS=-D_GNU_SOURCE
+
+ econf || die "./configure failed"
+ emake || die "compilation failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc NEWS README docs/*
+}