summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-2.24.2.ebuild')
-rw-r--r--dev-libs/glib/glib-2.24.2.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-libs/glib/glib-2.24.2.ebuild b/dev-libs/glib/glib-2.24.2.ebuild
index dfcff2188815..685fd69c15a3 100644
--- a/dev-libs/glib/glib-2.24.2.ebuild
+++ b/dev-libs/glib/glib-2.24.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.24.2.ebuild,v 1.1 2010/09/03 10:39:05 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.24.2.ebuild,v 1.2 2010/09/08 20:41:23 eva Exp $
EAPI="2"
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.gtk.org/"
LICENSE="LGPL-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam hardened selinux xattr"
+IUSE="debug doc fam selinux xattr"
RDEPEND="virtual/libiconv
xattr? ( sys-apps/attr )
@@ -29,11 +29,6 @@ DEPEND="${RDEPEND}
# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
src_prepare() {
- if use ppc64 && use hardened ; then
- replace-flags -O[2-3] -O1
- epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
- fi
-
if use ia64 ; then
# Only apply for < 4.1
local major=$(gcc-major-version)