summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/atlas')
-rw-r--r--dev-libs/atlas/Manifest10
-rw-r--r--dev-libs/atlas/atlas-3.2.1-r1.ebuild16
-rw-r--r--dev-libs/atlas/atlas-3.2.1.ebuild16
3 files changed, 21 insertions, 21 deletions
diff --git a/dev-libs/atlas/Manifest b/dev-libs/atlas/Manifest
index 839c09a0d482..2085e2aa476e 100644
--- a/dev-libs/atlas/Manifest
+++ b/dev-libs/atlas/Manifest
@@ -1,10 +1,10 @@
-MD5 fd959682a17d471557198d9cf54db10c atlas-3.2.1-r1.ebuild 1902
-MD5 fa3324f6e76e486717f54d75c495ebe8 atlas-3.2.1.ebuild 1907
-MD5 b16ad5206cc2b8556dc234acbd777a41 atlas-3.4.2.ebuild 1867
-MD5 e3feaec5bfd0ce662a659fa2f5bc907c atlas-3.4.1.ebuild 1856
MD5 2e814af09893f40622ba56e442b20c45 ChangeLog 1274
+MD5 48c2ff20b8889ba44834c0d01dd6250a atlas-3.2.1-r1.ebuild 1897
+MD5 d94c26fbab5e2e5d4e09fcdea783190c atlas-3.2.1.ebuild 1902
+MD5 e3feaec5bfd0ce662a659fa2f5bc907c atlas-3.4.1.ebuild 1856
+MD5 b16ad5206cc2b8556dc234acbd777a41 atlas-3.4.2.ebuild 1867
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1 60
+MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1-r1 60
MD5 ab8ce0151b53d1da05325b0f7294da48 files/digest-atlas-3.4.1 64
MD5 e4430c91578bb055dad2d25c1d880cfa files/digest-atlas-3.4.2 64
-MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1-r1 60
diff --git a/dev-libs/atlas/atlas-3.2.1-r1.ebuild b/dev-libs/atlas/atlas-3.2.1-r1.ebuild
index dfc5b7484261..a614c55417be 100644
--- a/dev-libs/atlas/atlas-3.2.1-r1.ebuild
+++ b/dev-libs/atlas/atlas-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.2.1-r1.ebuild,v 1.4 2003/08/05 19:01:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.2.1-r1.ebuild,v 1.5 2003/09/06 22:29:24 msterret Exp $
DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)"
HOMEPAGE="http://math-atlas.sourceforge.net/"
@@ -15,7 +15,7 @@ DEPEND="virtual/glibc"
S=${WORKDIR}/ATLAS
src_compile() {
-
+
#Make is actually an interactive configuration step.
#The configuration is highly sensitive to your specific machine.
#Although it is quite good, it will default to accuracy over speed.
@@ -23,7 +23,7 @@ src_compile() {
# by uncommenting the next line and commenting the yes ""| make || die line .
# make || die
-#atlas will automatically do a parallel make if possible.
+#atlas will automatically do a parallel make if possible.
yes "" | make || die
#Let's go grab the architecture determined by the configure
@@ -37,17 +37,17 @@ src_compile() {
cd ${S}
#This doesn't install into the live / file system.
#It installs into ${S}/lib/Linux*
- make install arch=${ATLAS_ARCH} || die
+ make install arch=${ATLAS_ARCH} || die
}
src_install () {
cd ${S}/lib/${ATLAS_ARCH}
-
+
insinto /usr/lib
dolib.a libatlas.a libcblas.a libf77blas.a libtstatlas.a
-
+
#the atlas liblapack.a library is not a complete lapack library,
#just the atlas optimizable objects. Store it some place safe
#where we can grab it when building the complete lapack library.
@@ -55,12 +55,12 @@ src_install () {
doins liblapack.a
cd ${S}/include/${ATLAS_ARCH}
-
+
insinto /usr/include
doins *.h
cd ${S}
-
+
dodoc README INSTALL.txt
dodoc doc/*.txt
insinto /usr/share/doc/${P}/ps
diff --git a/dev-libs/atlas/atlas-3.2.1.ebuild b/dev-libs/atlas/atlas-3.2.1.ebuild
index 4b5810b2e8e5..2b99feeeb528 100644
--- a/dev-libs/atlas/atlas-3.2.1.ebuild
+++ b/dev-libs/atlas/atlas-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.2.1.ebuild,v 1.8 2003/08/05 19:01:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.2.1.ebuild,v 1.9 2003/09/06 22:29:24 msterret Exp $
DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)"
HOMEPAGE="http://math-atlas.sourceforge.net/"
@@ -15,7 +15,7 @@ DEPEND="virtual/glibc"
S=${WORKDIR}/ATLAS
src_compile() {
-
+
#Make is actually an interactive configuration step.
#The configuration is highly sensitive to your specific machine.
#Although it is quite good, it will default to accuracy over speed.
@@ -23,7 +23,7 @@ src_compile() {
# by uncommenting the next line and commenting the yes ""| make || die line .
# make || die
-#atlas will automatically do a parallel make if possible.
+#atlas will automatically do a parallel make if possible.
yes "" | make || die
#Let's go grab the architecture determined by the configure
@@ -37,17 +37,17 @@ src_compile() {
cd ${S}
#This doesn't install into the live / file system.
#It installs into ${S}/lib/Linux*
- make install arch=${ATLAS_ARCH} || die
+ make install arch=${ATLAS_ARCH} || die
}
src_install () {
cd ${S}/lib/${ATLAS_ARCH}
-
+
insinto /usr/lib
dolib.a libatlas.a libcblas.a libf77blas.a libtstatlas.a
-
+
#the atlas liblapack.a library is not a complete lapack library,
#just the atlas optimizable objects. Store it some place safe
#where we can grab it when building the complete lapack library.
@@ -55,12 +55,12 @@ src_install () {
doins liblapack.a
cd ${S}/include/${ATLAS_ARCH}
-
+
insinto /usr/include
doins *.h
cd ${S}
-
+
dodoc README INSTALL.txt
dodoc doc/*.txt
insinto /usr/share/doc/${P}/ps