summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild')
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
index 5fe0d543321d..44503f078929 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild,v 1.7 2005/10/18 19:20:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.08-r1.ebuild,v 1.8 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -15,7 +15,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm-1.4.2"
KEYWORDS="-* x86"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.1.5
sys-apps/sed"
@@ -85,7 +85,9 @@ src_install() {
dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt
dohtml Welcome.html ControlPanel.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -155,9 +157,10 @@ pkg_postinst () {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}