summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild')
-rw-r--r--dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild b/dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild
index 492c6f96788d..903c76a4032a 100644
--- a/dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild
+++ b/dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild,v 1.23 2005/10/18 19:22:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jre/blackdown-jre-1.3.1-r9.ebuild,v 1.24 2005/10/18 20:20:51 agriffis Exp $
inherit java toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="ppc? ( http://distro.ibiblio.org/pub/Linux/distributions/yellowdog/soft
LICENSE="sun-bcla-java-vm"
SLOT="0"
KEYWORDS="ppc -*"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND="virtual/libc
>=dev-java/java-config-0.2.5
@@ -50,7 +50,9 @@ src_install() {
dodoc COPYRIGHT LICENSE README INSTALL
dohtml README.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
case ${ARCH} in
amd64|x86) platform="i386" ;;
ppc) platform="ppc" ;;
@@ -63,9 +65,10 @@ src_install() {
set_java_env ${FILESDIR}/${VMHANDLE}
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}