summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/pnet/pnet-0.5.12.ebuild')
-rw-r--r--dev-dotnet/pnet/pnet-0.5.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-dotnet/pnet/pnet-0.5.12.ebuild b/dev-dotnet/pnet/pnet-0.5.12.ebuild
new file mode 100644
index 000000000000..2d10d0bbc67b
--- /dev/null
+++ b/dev-dotnet/pnet/pnet-0.5.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnet/pnet-0.5.12.ebuild,v 1.1 2003/09/06 12:14:44 scandium Exp $
+
+DESCRIPTION="Portable .NET runtime, compiler, tools"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="mirror://gnu/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=dev-util/treecc-0.2.6
+ !dev-dotnet/mono"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README
+ dodoc doc/gtk-sharp.HOWTO
+ dohtml doc/*.html
+
+ # init script
+ exeinto /etc/init.d ; newexe ${PORTDIR}/dev-dotnet/mono/files/dotnet.init dotnet
+ insinto /etc/conf.d ; newins ${PORTDIR}/dev-dotnet/mono/files/dotnet.conf dotnet
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you want to avoid typing '<runtime> program.exe'"
+ einfo "you can configure your runtime in /etc/conf.d/dotnet"
+ einfo "Use /etc/init.d/dotnet to register your runtime"
+ echo
+}