summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog5
-rw-r--r--dev-db/tora/tora-1.3.13.ebuild22
2 files changed, 15 insertions, 12 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index 1d77a365de43..28cf28c2f832 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.23 2004/04/20 15:38:26 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.24 2004/06/10 20:08:32 rizzo Exp $
+
+ 10 Jun 2004; Don Seiler <rizzo@gentoo.org> tora-1.3.13.ebuild:
+ Fixing USE usage, thanks to agriffis and vapier for the science.
20 Apr 2004; Don Seiler <rizzo@gentoo.org>; tora-1.3.13.ebuild:
Adding debug support
diff --git a/dev-db/tora/tora-1.3.13.ebuild b/dev-db/tora/tora-1.3.13.ebuild
index 025c35cf2cfb..849bf0637e1a 100644
--- a/dev-db/tora/tora-1.3.13.ebuild
+++ b/dev-db/tora/tora-1.3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.13.ebuild,v 1.5 2004/04/20 15:38:26 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.13.ebuild,v 1.6 2004/06/10 20:08:32 rizzo Exp $
use debug && inherit debug
@@ -18,16 +18,16 @@ DEPEND=">=x11-libs/qt-3.0.0
kde? ( >=kde-base/kdelibs-3.1 )"
pkg_setup() {
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- ewarn "ORACLE_HOME variable is not set."
- ewarn
- ewarn "You must install Oracle >= 8i client for Linux in"
- ewarn "order to compile TOra with Oracle support."
- ewarn
- ewarn "Otherwise specify -oci8 in your USE variable."
- ewarn
- ewarn "You can download the Oracle software from"
- ewarn "http://otn.oracle.com/software/content.html"
+ if use oci8 && [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "Otherwise specify -oci8 in your USE variable."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://otn.oracle.com/software/content.html"
die
fi
}