summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/sqlite-3.8.10.1.ebuild9
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 4ced4f7b0e79..b5ffb7a80593 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.566 2015/05/15 11:55:43 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.567 2015/05/15 12:11:12 idella4 Exp $
+
+ 15 May 2015; Ian Delaney <idella4@gentoo.org> sqlite-3.8.10.1.ebuild:
+ Fix parallel building with USE="-tcl -test -tools" (bug #549412).
+ Patch by Arfrever.
15 May 2015; Pacho Ramos <pacho@gentoo.org> sqlite-3.8.10.1.ebuild:
ppc stable wrt bug #549258
diff --git a/dev-db/sqlite/sqlite-3.8.10.1.ebuild b/dev-db/sqlite/sqlite-3.8.10.1.ebuild
index 5172563cd051..f680da89f25c 100644
--- a/dev-db/sqlite/sqlite-3.8.10.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.8.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.10.1.ebuild,v 1.6 2015/05/15 11:55:43 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.10.1.ebuild,v 1.7 2015/05/15 12:11:12 idella4 Exp $
EAPI="5"
@@ -54,6 +54,12 @@ pkg_setup() {
src_prepare() {
if amalgamation; then
epatch "${FILESDIR}/${PN}-3.8.1-autoconf-dlopen_check.patch"
+
+ # http://www.sqlite.org/cgi/src/info/85bfa9a67f997084
+ sed \
+ -e "s/^sqlite3_SOURCES = shell.c sqlite3.h$/sqlite3_SOURCES = shell.c sqlite3.c sqlite3.h/" \
+ -e "s/^sqlite3_LDADD = sqlite3.\$(OBJEXT) @READLINE_LIBS@$/sqlite3_LDADD = @READLINE_LIBS@\nsqlite3_CFLAGS = \$(AM_CFLAGS)/" \
+ -i Makefile.am
else
epatch "${FILESDIR}/${PN}-3.8.1-src-dlopen_check.patch"
epatch "${FILESDIR}/${PN}-3.8.1-tests-icu-52.patch"
@@ -138,6 +144,7 @@ src_configure() {
append-cppflags -DSQLITE_OMIT_WAL
fi
+ # Use pread(), pread64(), pwrite(), pwrite64() functions for better performance if they are available.
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -Werror=implicit-function-declaration -x c - -o "${T}/pread_pwrite_test" <<< $'#include <unistd.h>\nint main()\n{\n pread(0, NULL, 0, 0);\n pwrite(0, NULL, 0, 0);\n return 0;\n}' &> /dev/null; then
append-cppflags -DUSE_PREAD
fi