summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite/sqlite-3.3.12.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-3.3.12.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-db/sqlite/sqlite-3.3.12.ebuild b/dev-db/sqlite/sqlite-3.3.12.ebuild
index f58cb49780ed..587e69554dd4 100644
--- a/dev-db/sqlite/sqlite-3.3.12.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.10 2007/05/06 19:54:44 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.11 2007/05/23 01:14:54 cardoe Exp $
inherit eutils alternatives libtool
@@ -21,19 +21,13 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+RESTRICT="tcl? ( test )"
+
src_unpack() {
# test
- if has test ${FEATURES} ; then
- if ! has userpriv ${FEATURES} ; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl ; then
- eerror "The tcl USE flag must be enabled to run tests."
- ewarn "Please note that turning on tcl installs runtime"
- ewarn "support too."
- eerror "Testsuite will not be run."
- fi
+ if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
fi
unpack ${A}