summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/opendbx/opendbx-1.3.4.ebuild')
-rw-r--r--dev-db/opendbx/opendbx-1.3.4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-db/opendbx/opendbx-1.3.4.ebuild b/dev-db/opendbx/opendbx-1.3.4.ebuild
index f30dc190aea3..f18f4824d65c 100644
--- a/dev-db/opendbx/opendbx-1.3.4.ebuild
+++ b/dev-db/opendbx/opendbx-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.3.4.ebuild,v 1.2 2007/11/03 09:36:35 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.3.4.ebuild,v 1.3 2007/12/05 22:08:49 swegener Exp $
inherit flag-o-matic
@@ -11,18 +11,18 @@ SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="firebird mysql oracle postgres sqlite sqlite3"
+IUSE="bindist firebird mysql oracle postgres sqlite sqlite3"
DEPEND="mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
sqlite? ( <dev-db/sqlite-3 )
sqlite3? ( =dev-db/sqlite-3* )
oracle? ( dev-db/oracle-instantclient-basic )
- firebird? ( dev-db/firebird )"
+ !bindist? ( firebird? ( dev-db/firebird ) )"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
+ if ! ( use !bindist && use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
then
die "Need at least one of firebird, mysql, oracle, postgres, sqlite and sqlite3 activated!"
fi
@@ -40,7 +40,7 @@ pkg_setup() {
src_compile() {
local backends=""
- use firebird && backends="${backends} firebird"
+ use !bindist && use firebird && backends="${backends} firebird"
use mysql && backends="${backends} mysql"
use oracle && backends="${backends} oracle"
use postgres && backends="${backends} pgsql"