summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/xephem/xephem-3.5.2.ebuild')
-rw-r--r--app-sci/xephem/xephem-3.5.2.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/app-sci/xephem/xephem-3.5.2.ebuild b/app-sci/xephem/xephem-3.5.2.ebuild
index 9b222f65f195..954b57497060 100644
--- a/app-sci/xephem/xephem-3.5.2.ebuild
+++ b/app-sci/xephem/xephem-3.5.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/xephem/xephem-3.5.2.ebuild,v 1.3 2002/07/25 16:18:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xephem/xephem-3.5.2.ebuild,v 1.4 2002/08/19 00:32:52 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="XEphem is the X Windows Ephemeris, and provides a scientific-grade solar system model, star charts, sky views, plus a whole lot more."
-SRC_URI=""
+SRC_URI="xephem-${PV}.tar.gz"
HOMEPAGE="http://www.clearskyinstitute.com/xephem"
KEYWORDS="x86"
SLOT="0"
@@ -17,18 +17,23 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${P}.tar.gz
-}
-
src_compile() {
cd libastro
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS=.*:CFLAGS=${CFLAGS} -ffast-math -Wall:" \
+ Makefile.orig > Makefile
emake || die
cd ../libip
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS=*:CFLAGS=${CFLAGS} -I../libastro -ffast-math -Wall:" \
+ Makefile.orig > Makefile
emake || die
cd ../GUI/xephem
xmkmf
+ mv Makefile Makefile.orig
+ sed -e "s:CDEBUGFLAGS = .*:CDEBUGFLAGS = ${CFLAGS} -fno-strength-reduce:" \
+ Makefile.orig > Makefile
emake || die
}
@@ -51,7 +56,8 @@ XEphem.ShareDir: /opt/xephem
EOT
insinto /usr/lib/X11/app-defaults/
doins ${S}/XEphem
-
- dodoc Copyright README
-
+
+ dodoc Copyright README INSTALL
+ mv ${S}/GUI/xephem/xephem.man ${S}/xephem.1
+ doman ${S}/xephem.1
}