summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/krita')
-rw-r--r--app-office/krita/ChangeLog7
-rw-r--r--app-office/krita/files/digest-krita-1.4.01
-rw-r--r--app-office/krita/krita-1.4.0.ebuild40
3 files changed, 47 insertions, 1 deletions
diff --git a/app-office/krita/ChangeLog b/app-office/krita/ChangeLog
index 570991e89972..d8cafac0646d 100644
--- a/app-office/krita/ChangeLog
+++ b/app-office/krita/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/krita
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/krita/ChangeLog,v 1.3 2005/06/11 09:46:56 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/krita/ChangeLog,v 1.4 2005/06/21 08:41:34 greg_g Exp $
+
+*krita-1.4.0 (21 Jun 2005)
+
+ 21 Jun 2005; Gregorio Guidi <greg_g@gentoo.org> +krita-1.4.0.ebuild:
+ Final release of KOffice 1.4.
11 Jun 2005; Markus Rothe <corsair@gentoo.org> krita-1.4.0_rc1.ebuild:
Added ~ppc64; bug #95128
diff --git a/app-office/krita/files/digest-krita-1.4.0 b/app-office/krita/files/digest-krita-1.4.0
new file mode 100644
index 000000000000..aada0edc41ee
--- /dev/null
+++ b/app-office/krita/files/digest-krita-1.4.0
@@ -0,0 +1 @@
+MD5 3e6fd9f92024de68e5879c22d02a33c5 koffice-1.4.0.tar.bz2 19730186
diff --git a/app-office/krita/krita-1.4.0.ebuild b/app-office/krita/krita-1.4.0.ebuild
new file mode 100644
index 000000000000..f7325f5ebca7
--- /dev/null
+++ b/app-office/krita/krita-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/krita/krita-1.4.0.ebuild,v 1.1 2005/06/21 08:41:34 greg_g Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice image manipulation program."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="javascript"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ media-libs/lcms
+ javascript? ( kde-base/kjsembed )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoscript lib/koscript
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMEXTRA="filters/krita"
+
+need-kde 3.3