summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tdl/tdl-1.4.1.ebuild')
-rw-r--r--app-misc/tdl/tdl-1.4.1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/app-misc/tdl/tdl-1.4.1.ebuild b/app-misc/tdl/tdl-1.4.1.ebuild
index b2021022429b..d6afdb7ea2ba 100644
--- a/app-misc/tdl/tdl-1.4.1.ebuild
+++ b/app-misc/tdl/tdl-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.4.1.ebuild,v 1.5 2003/08/17 11:38:02 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.4.1.ebuild,v 1.6 2003/09/03 03:59:57 dholm Exp $
DESCRIPTION="Command line To Do List manager"
HOMEPAGE="http://www.rc0.org.uk/tdl/"
@@ -8,10 +8,10 @@ SRC_URI="http://www.rrbcurnow.freeuk.com/tdl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 alpha"
+KEYWORDS="x86 alpha ~ppc"
IUSE="readline ncurses doc"
-RDEPEND="readline? ( >=sys-libs/readline-4.3
+RDEPEND="readline? ( >=sys-libs/readline-4.3
ncurses? ( sys-libs/ncurses )
!ncurses? ( sys-libs/libtermcap-compat ) )"
DEPEND="${RDEPEND}
@@ -22,7 +22,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}
src_compile() {
- local myconf="--prefix=/usr"
+ local myconf="--prefix=/usr"
if ! use readline; then
myconf="${myconf} --without-readline"
@@ -33,19 +33,19 @@ src_compile() {
sed -i 's#-lncurses##g' ${S}/configure
fi
fi
-
+
./configure ${myconf} || die "configure failed, sorry!"
emake all tdl.info tdl.html tdl.txt || die
- use doc && emake tdl.dvi tdl.ps tdl.pdf
+ use doc && emake tdl.dvi tdl.ps tdl.pdf
}
src_install() {
local i
-
+
dodoc COPYING README NEWS tdl.txt ${FILESDIR}/screenshot.png
doinfo tdl.info
dohtml tdl.html
-
+
dobin tdl
doman tdl.1
@@ -55,7 +55,7 @@ src_install() {
dosym tdl.1 /usr/share/man/man1/${i}.1
done
- prepallman
-
+ prepallman
+
use doc && dodoc tdl.dvi tdl.ps tdl.pdf
}