summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-7.0_alpha20050809.ebuild')
-rw-r--r--app-editors/vim/vim-7.0_alpha20050809.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.0_alpha20050809.ebuild b/app-editors/vim/vim-7.0_alpha20050809.ebuild
new file mode 100644
index 000000000000..ff6cd3ddf4e2
--- /dev/null
+++ b/app-editors/vim/vim-7.0_alpha20050809.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0_alpha20050809.ebuild,v 1.1 2005/08/09 22:59:10 ciaranm Exp $
+
+inherit vim
+
+VIM_DATESTAMP="${PV##*alpha}"
+
+VIM_VERSION="7.0aa"
+VIM_SNAPSHOT="vim-${PV}.tar.bz2"
+VIM_GENTOO_PATCHES="vim-${PV}-gentoo-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~x86 ~sparc ~mips ~ppc ~amd64 ~ppc64 ~alpha"
+IUSE=""
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}"
+RDEPEND="${RDEPEND} !app-editors/nvi"