summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hteditor/hteditor-0.9.1.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-0.9.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/hteditor/hteditor-0.9.1.ebuild b/app-editors/hteditor/hteditor-0.9.1.ebuild
new file mode 100644
index 000000000000..c10aff6905f9
--- /dev/null
+++ b/app-editors/hteditor/hteditor-0.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-0.9.1.ebuild,v 1.1 2005/09/25 02:52:43 dragonheart Exp $
+
+DESCRIPTION="editor for executable files"
+HOMEPAGE="http://hte.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hte/ht-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.4
+ sys-devel/autoconf
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/ht-${PV}"
+
+src_compile() {
+ econf || die
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS KNOWNBUGS TODO README
+ dohtml doc/ht.html
+ doinfo doc/*.info
+}