summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/autobook/autobook-1.5.ebuild')
-rw-r--r--app-doc/autobook/autobook-1.5.ebuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/app-doc/autobook/autobook-1.5.ebuild b/app-doc/autobook/autobook-1.5.ebuild
index e94a9b234a2d..90cf672bdf43 100644
--- a/app-doc/autobook/autobook-1.5.ebuild
+++ b/app-doc/autobook/autobook-1.5.ebuild
@@ -1,17 +1,31 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/autobook/autobook-1.5.ebuild,v 1.1 2006/11/19 21:19:04 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/autobook/autobook-1.5.ebuild,v 1.2 2006/11/26 12:27:56 vapier Exp $
DESCRIPTION="GNU Autoconf, Automake and Libtool"
HOMEPAGE="http://sources.redhat.com/autobook/"
-SRC_URI="http://sources.redhat.com/autobook/${P}.tar.gz"
+SRC_URI="http://sources.redhat.com/autobook/${P}.tar.gz
+ examples? (
+ http://sources.redhat.com/autobook/foonly-2.0.tar.gz
+ http://sources.redhat.com/autobook/small-2.0.tar.gz
+ http://sources.redhat.com/autobook/hello-2.0.tar.gz
+ http://sources.redhat.com/autobook/convenience-2.0.tar.gz
+ )"
LICENSE="OPL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="examples"
+
DEPEND=""
src_install() {
- dohtml *
+ dohtml * || die
+ if use examples ; then
+ local d
+ for d in {convenience,foonly,hello,small}-2.0 ; do
+ insinto /usr/share/doc/${PF}/${d}
+ doins -r "${WORKDIR}"/${d}/* || die "doins ${d} failed"
+ done
+ fi
}