summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/heimdal/heimdal-0.7.1-r1.ebuild')
-rw-r--r--app-crypt/heimdal/heimdal-0.7.1-r1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild b/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild
index d787d9121d06..1f751d582d4d 100644
--- a/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild,v 1.1 2005/09/18 14:11:09 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild,v 1.2 2005/10/03 12:26:25 seemant Exp $
-inherit libtool eutils virtualx toolchain-funcs
+inherit autotools libtool eutils virtualx toolchain-funcs
PATCHVER=0.1
PATCH_P=${P}-gentoo-patches-${PATCHVER}
@@ -43,14 +43,12 @@ src_unpack() {
epatch ${GENTOODIR}/patches
}
-src_compile() {
+src_COMPILE() {
+ ebegin "Running autoreconf"
+ AT_M4DIR="cf" eautoreconf
+ eend $?
elibtoolize
- aclocal -I cf || die "configure problem"
- autoheader || die "configure problem"
- automake -a || die "configure problem"
- autoconf || die "configure problem"
-
local myconf=""
use krb4 \
@@ -58,8 +56,6 @@ src_compile() {
use ldap && myconf="${myconf} --with-openldap=/usr"
- libtoolize --copy --force
-
econf \
$(use_with ipv6) \
$(use_with berkdb berkeley-db) \