summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lzma/lzma-4.63.ebuild')
-rw-r--r--app-arch/lzma/lzma-4.63.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/lzma/lzma-4.63.ebuild b/app-arch/lzma/lzma-4.63.ebuild
new file mode 100644
index 000000000000..400d7e00e3b9
--- /dev/null
+++ b/app-arch/lzma/lzma-4.63.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-4.63.ebuild,v 1.1 2009/01/25 19:56:29 radek Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="http://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${PN}463.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ia64 ~mips ~sparc ~x86"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Compress/LZMA_Alone
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS}" \
+ || die "Make failed"
+}
+
+src_install() {
+ newbin CPP/7zip/Compress/LZMA_Alone/lzma lzma_alone|| die
+ dodoc history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt lzma.txt Methods.txt
+
+ einfo "Starting from app-arch/lzma version 4.63 binary name was changed"
+ einfo "to /usr/bin/lzma_alone to avoid conflict with lzma-utils package"
+}
+
+