summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sudo/sudo-1.6.5_p1.ebuild')
-rw-r--r--app-admin/sudo/sudo-1.6.5_p1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/sudo/sudo-1.6.5_p1.ebuild b/app-admin/sudo/sudo-1.6.5_p1.ebuild
new file mode 100644
index 000000000000..83ef4cf299dd
--- /dev/null
+++ b/app-admin/sudo/sudo-1.6.5_p1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.6.5_p1.ebuild,v 1.1 2002/01/18 07:41:24 drobbins Exp $
+
+NP=sudo-1.6.5p1
+S=${WORKDIR}/${NP}
+DESCRIPTION="Allows certain users/groups to run commands as root"
+SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${NP}.tar.gz"
+HOMEPAGE="http://www.sudo.ws/"
+
+DEPEND="virtual/glibc pam? ( >=sys-libs/pam-0.73-r1 )"
+
+src_compile() {
+ local myconf
+ if [ "`use pam`" ]
+ then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ ./configure --prefix=/usr --host=${CHOST} --mandir=/usr/share/man --sysconfdir=/etc --with-all-insults --disable-path-info $myconf || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
+ dodoc BUGS CHANGES FAQ HISTORY LICENSE PORTING README RUNSON TODO TROUBLESHOOTING UPGRADE sample.*
+ insinto /etc/pam.d
+ doins ${FILESDIR}/sudo
+}
+