summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwgen/pwgen-2.01.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.01.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-admin/pwgen/pwgen-2.01.ebuild b/app-admin/pwgen/pwgen-2.01.ebuild
index 03baa474ac1c..dc596d9d36a1 100644
--- a/app-admin/pwgen/pwgen-2.01.ebuild
+++ b/app-admin/pwgen/pwgen-2.01.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.5 2002/07/17 20:43:17 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.6 2002/07/25 13:17:40 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Password Generator"
SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
-SLOT="0"
HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+
+SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86"
DEPEND="virtual/glibc"
src_compile() {
# Fix the Makefile
cp Makefile.in Makefile.in.new
- sed -e 's:$(prefix)/man/man1:$(mandir)/man1:g' Makefile.in.new > Makefile.in
+ sed -e 's:$(prefix)/man/man1:$(mandir)/man1:g' \
+ Makefile.in.new > Makefile.in
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --sysconfdir=/etc/pwgen || die "./configure failed"
-
+ econf --sysconfdir=/etc/pwgen || die "./configure failed"
emake || die
}