summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/Manifest12
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.3.41
-rw-r--r--net-ftp/lftp/lftp-3.3.4.ebuild68
4 files changed, 77 insertions, 11 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 23a7ba0543bc..0bcb0d4be17e 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.89 2005/11/13 12:35:48 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.90 2005/11/19 23:39:40 dragonheart Exp $
+
+*lftp-3.3.4 (19 Nov 2005)
+
+ 19 Nov 2005; Daniel Black <dragonheart@gentoo.org> +lftp-3.3.4.ebuild:
+ version bump
*lftp-3.3.3 (13 Nov 2005)
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index 8e52982da460..12eaec0ce91b 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 6306d2a88363c56000b077029d99af01 ChangeLog 13117
MD5 8e29dd236e9977e83aee442106844d7e files/digest-lftp-3.0.13 65
MD5 0401db3592b8f8ee8b750f12b84cfde3 files/digest-lftp-3.3.0 63
MD5 500f6bc400867598be6e6ef4ee5274a5 files/digest-lftp-3.3.3 63
+MD5 16ab74adb63da682a17a18f1d7885b91 files/digest-lftp-3.3.4 63
MD5 929ba0e30bdea8ef09f54152b9aa0c8f lftp-3.0.13.ebuild 1804
MD5 2e06b00d03a53136c81d8d8e18c6c13f lftp-3.3.0.ebuild 1777
MD5 c77bd1b11f4e4a6a066d37118b14196f lftp-3.3.3.ebuild 1777
+MD5 c77bd1b11f4e4a6a066d37118b14196f lftp-3.3.4.ebuild 1777
MD5 bd30469259dd912781df916084edcacd metadata.xml 430
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFDdzMxmdTrptrqvGERAjUjAJ4peq/v7q/ts+A5bBTzDR830jrFhgCdEsAT
-+DsR6uU5OkO8pqvWGOiRPJg=
-=gAAn
------END PGP SIGNATURE-----
diff --git a/net-ftp/lftp/files/digest-lftp-3.3.4 b/net-ftp/lftp/files/digest-lftp-3.3.4
new file mode 100644
index 000000000000..e75f06f930d8
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.3.4
@@ -0,0 +1 @@
+MD5 3811e0e60aeb22a62d231907f08cfc32 lftp-3.3.4.tar.gz 1728880
diff --git a/net-ftp/lftp/lftp-3.3.4.ebuild b/net-ftp/lftp/lftp-3.3.4.ebuild
new file mode 100644
index 000000000000..e86ef61c4553
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.3.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.3.4.ebuild,v 1.1 2005/11/19 23:39:40 dragonheart Exp $
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program"
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ nls? ( sys-devel/gettext )
+ socks5? ( >=net-proxy/dante-1.1.12 )
+ socks5? ( virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ sys-libs/readline
+ virtual/libc"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=sys-apps/sed-4
+ sys-apps/gawk
+ sys-devel/bison
+ sys-devel/libtool"
+
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}