summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.6.1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index 9a59f4ae27f1..68bb95d956fd 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.93 2010/09/12 21:29:24 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.94 2010/09/16 10:05:09 wired Exp $
+
+*gtk-engines-qtcurve-1.6.1 (16 Sep 2010)
+
+ 16 Sep 2010; Alex Alexander <wired@gentoo.org>
+ +gtk-engines-qtcurve-1.6.1.ebuild:
+ version bump
*gtk-engines-qtcurve-1.6.0 (12 Sep 2010)
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.6.1.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.6.1.ebuild
new file mode 100644
index 000000000000..7819bcd9f449
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.6.1.ebuild,v 1.1 2010/09/16 10:05:09 wired Exp $
+
+EAPI=1
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozilla firefox3"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ firefox3? ( || ( >=www-client/firefox-3.0
+ >=www-client/firefox-bin-3.0 ) )"
+DEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_OLD_MOZILLA=true"
+ use firefox3 && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_OLD_MOZILLA=false"
+ cmake-utils_src_compile
+}