summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/Manifest2
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.191
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.19.ebuild75
4 files changed, 84 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index 508f026fd01f..2fd968000fb1 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.43 2004/06/25 01:04:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.44 2004/07/17 12:20:42 zul Exp $
+
+*mod_ssl-2.8.19 (18 Jul 2004)
+
+ 18 Jul 2004; Chuck Short <zul@gentoo.org> mod_ssl-2.8.19.ebuild:
+ Version bump, cloes #57379.
20 Jun 2004; Chuck Short <zul@gentoo.org> mod_ssl-2.8.17.ebuild,
mod_ssl-2.8.18.ebuild:
diff --git a/net-www/mod_ssl/Manifest b/net-www/mod_ssl/Manifest
index 8f3c4740e081..4d5ae78a5561 100644
--- a/net-www/mod_ssl/Manifest
+++ b/net-www/mod_ssl/Manifest
@@ -1,5 +1,6 @@
MD5 9eba5451e8883ea7e9cedf5b02c97e62 mod_ssl-2.8.18.ebuild 2183
MD5 7f02b177b06559b9aab3444c173343bc mod_ssl-2.8.17.ebuild 2183
+MD5 4dca7628287f921f6aba1ed72ba14cfd mod_ssl-2.8.19.ebuild 2186
MD5 c6a1cc5e60fda91d6d0fa56a6aa0c413 ChangeLog 5260
MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
MD5 22519ecbd59e494943b65af55c81e5cd files/ssl.default-vhost.conf 6977
@@ -7,3 +8,4 @@ MD5 559aa3cfd0e290af8ca0aca3d024c58d files/mod_ssl.conf 2448
MD5 6d5778e2221ca4b45270d4367939294f files/gentestcrt.sh 8798
MD5 9ba9eb8eced950cd59cb8dadd090f908 files/digest-mod_ssl-2.8.17 73
MD5 f53031df0c0d1a5bd75a9151d0810e9e files/digest-mod_ssl-2.8.18 73
+MD5 89239995d079a1bd9abc580e2264c71b files/digest-mod_ssl-2.8.19 73
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.19 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.19
new file mode 100644
index 000000000000..33762abd3d68
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.19
@@ -0,0 +1 @@
+MD5 ae2becebfec3784f9342932581e1cc9d mod_ssl-2.8.19-1.3.31.tar.gz 754277
diff --git a/net-www/mod_ssl/mod_ssl-2.8.19.ebuild b/net-www/mod_ssl/mod_ssl-2.8.19.ebuild
new file mode 100644
index 000000000000..c1c64c1c154c
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.19.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.19.ebuild,v 1.1 2004/07/17 12:20:42 zul Exp $
+
+MY_P=${P}-1.3.31
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="x86 ~ppc sparc ~alpha ~hppa"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="=net-www/apache-1.3.31*
+ >=dev-libs/openssl-0.9.6k"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}