summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/insight/ChangeLog7
-rw-r--r--dev-util/insight/files/digest-insight-6.7.13
-rw-r--r--dev-util/insight/insight-6.7.1.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-util/insight/ChangeLog b/dev-util/insight/ChangeLog
index ec0bde9b4ddf..7ca772a0afd3 100644
--- a/dev-util/insight/ChangeLog
+++ b/dev-util/insight/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/insight
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/ChangeLog,v 1.40 2007/07/22 07:24:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/ChangeLog,v 1.41 2007/11/09 08:41:38 vapier Exp $
+
+*insight-6.7.1 (09 Nov 2007)
+
+ 09 Nov 2007; Mike Frysinger <vapier@gentoo.org> +insight-6.7.1.ebuild:
+ Version bump.
22 Jul 2007; Hans de Graaff <graaff@gentoo.org> insight-6.5.ebuild:
Drop virtual/x11 references.
diff --git a/dev-util/insight/files/digest-insight-6.7.1 b/dev-util/insight/files/digest-insight-6.7.1
new file mode 100644
index 000000000000..6f510e3732dd
--- /dev/null
+++ b/dev-util/insight/files/digest-insight-6.7.1
@@ -0,0 +1,3 @@
+MD5 cb329601b17f90bba32c29eab124f7e4 insight-6.7.1.tar.bz2 23172660
+RMD160 475429a4429c65db7a783072eb5f2b00f05ee530 insight-6.7.1.tar.bz2 23172660
+SHA256 c3b3fd534b1da4be279517e1755ce4fa65bc011ed0d62a1bb7e1aab219513542 insight-6.7.1.tar.bz2 23172660
diff --git a/dev-util/insight/insight-6.7.1.ebuild b/dev-util/insight/insight-6.7.1.ebuild
new file mode 100644
index 000000000000..382ec15baf20
--- /dev/null
+++ b/dev-util/insight/insight-6.7.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.7.1.ebuild,v 1.1 2007/11/09 08:41:38 vapier Exp $
+
+inherit eutils flag-o-matic
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="A graphical interface to the GNU debugger"
+HOMEPAGE="http://sourceware.org/insight/"
+SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="sys-libs/ncurses
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-6.6-DESTDIR.patch
+ epatch "${FILESDIR}"/${PN}-6.6-burn-paths.patch
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing # tcl code sucks
+ strip-linguas -u bfd/po opcodes/po
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ --enable-gdbtk \
+ --disable-tui \
+ --datadir=/usr/share/${PN} \
+ || die
+ emake || die
+}
+
+src_install() {
+ # the tcl-related subdirs are not parallel safe
+ emake -j1 DESTDIR="${D}" install || die
+
+ # Don't install docs when building a cross-insight
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ dodoc gdb/gdbtk/{README,TODO}
+ fi
+
+ # the gui tcl code does not consider any of the configure
+ # options given it ... instead, it requires the path to
+ # be /usr/share/redhat/...
+ mv "${D}"/usr/share/${PN}/redhat "${D}"/usr/share/ || die
+
+ # scrub all the cruft we dont want
+ local x
+ cd "${D}"/usr/bin
+ for x in * ; do
+ [[ ${x} != *insight ]] && rm -f ${x}
+ done
+ cd "${D}"
+ rm -rf usr/{include,man,share/{info,locale,man}}
+ rm -rf usr/lib*
+}