summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.1.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.2.ebuild8
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.3.ebuild8
3 files changed, 11 insertions, 11 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.4.1.ebuild b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
index 4b2457e4ddf2..8e25c443df6d 100644
--- a/sys-cluster/openmpi/openmpi-1.4.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.10 2010/12/16 15:59:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.11 2010/12/19 17:51:36 jlec Exp $
EAPI=2
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -72,9 +72,9 @@ src_configure() {
fi
if use fortran; then
- if [[ "$(tc-getFC)" = "g77" ]]; then
+ if [[ $(tc-getFC) =~ g77 ]]; then
myconf="${myconf} --disable-mpi-f90"
- elif [[ "$(tc-getFC)" = if* ]]; then
+ elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
myconf="${myconf} --with-mpi-f90-size=medium"
fi
diff --git a/sys-cluster/openmpi/openmpi-1.4.2.ebuild b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
index 16d071017a08..44024f00eccf 100644
--- a/sys-cluster/openmpi/openmpi-1.4.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.8 2010/12/16 15:59:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.9 2010/12/19 17:51:36 jlec Exp $
EAPI=3
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -55,7 +55,7 @@ src_prepare() {
src_configure() {
local myconf="
- --sysconfdir="${EPREFIX}"/etc/${PN}
+ --sysconfdir="${EPREFIX}/etc/${PN}"
--without-xgrid
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
@@ -68,9 +68,9 @@ src_configure() {
fi
if use fortran; then
- if [[ "$(tc-getFC)" = "g77" ]]; then
+ if [[ $(tc-getFC) =~ g77 ]]; then
myconf="${myconf} --disable-mpi-f90"
- elif [[ "$(tc-getFC)" = if* ]]; then
+ elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
myconf="${myconf} --with-mpi-f90-size=medium"
fi
diff --git a/sys-cluster/openmpi/openmpi-1.4.3.ebuild b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
index 7a194f613085..bced64769119 100644
--- a/sys-cluster/openmpi/openmpi-1.4.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.3 2010/12/16 15:59:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.4 2010/12/19 17:51:36 jlec Exp $
EAPI=3
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -55,7 +55,7 @@ src_prepare() {
src_configure() {
local myconf="
- --sysconfdir="${EPREFIX}"/etc/${PN}
+ --sysconfdir="${EPREFIX}/etc/${PN}"
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
--without-slurm"
@@ -67,9 +67,9 @@ src_configure() {
fi
if use fortran; then
- if [[ "$(tc-getFC)" = "g77" ]]; then
+ if [[ $(tc-getFC) =~ g77 ]]; then
myconf="${myconf} --disable-mpi-f90"
- elif [[ "$(tc-getFC)" = if* ]]; then
+ elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
myconf="${myconf} --with-mpi-f90-size=medium"
fi